Solution PT Activity 2.5.2: Challenge PPP Configuration

Task 1: Configure and Activate Serial and Ethernet Addresses
Step 1. Configure interfaces on R1, R2, and R3.

The addressing scheme is listed on the topology and in the Addressing Table. Some interface addresses are provided, but for some interfaces only the network is provided. In the cases where you are only given the network address, you may use any valid address on the specified network in order to be graded correctly in Packet Tracer.
Configure the interfaces for R1, R2, and R3 according to the topology. On the DCE sides of the serial links, the clock rate is 64000 bits.

R1
s0/0/0 172.16.0.1/30
s0/0/1 172.16.0.9/30

R2
s0/0/0 172.16.0.2/30
s0/0/1 172.16.0.5/30

R3
s0/0/0 172.16.0.10/30
s0/0/1 172.16.0.6/30

R1
Password: cisco
R1>en
Password: class
R1#conf t
R1(config)#int s0/0/0
R1(config-if)#ip address 172.16.0.1 255.255.255.252
R1(config-if)#no sh
R1(config-if)#clock rate 64000
R1(config-if)#exit
R1(config)#int s0/0/1
R1(config-if)#ip address 172.16.0.9 255.255.255.252
R1(config-if)#no sh
R1(config-if)#exit
R1(config)#int f0/1
R1(config-if)#ip address 10.0.0.1 255.255.255.128
R1(config-if)#no sh
R1(config-if)#exit

R2
Password: cisco
R2>en
Password: class
R2#conf t
R2(config)#int s0/0/0
R2(config-if)#ip address 172.16.0.2 255.255.255.252
R2(config-if)#no sh
R2(config-if)#exit
R2(config)#int s0/0/1
R2(config-if)#ip address 172.16.0.5 255.255.255.252
R2(config-if)#clock rate 64000
R2(config-if)#no sh
R2(config-if)#exit
R2(config)#int lo0
R2(config-if)#ip address 209.165.200.161 255.255.255.224
R2(config-if)#no sh
R2(config-if)#exit

R3
Password: cisco
R3>en
Password: class
R3#conf t
R3(config)#int s0/0/0
R3(config-if)#ip address 172.16.0.10 255.255.255.252
R3(config-if)#clock rate 64000
R3(config-if)#no sh
R3(config-if)#exit
R3(config)#int s0/0/1
R3(config-if)#ip address 172.16.0.6 255.255.255.252
R3(config-if)#no sh
R3(config-if)#exit
R3(config)#int f0/1
R3(config-if)#ip address 10.0.0.129 255.255.255.128
R3(config-if)#no sh

Step 2. Verify IP addressing and interfaces.
Verify that all the interfaces are up at both the physical and data link layers. Directly connected routers should be able to ping each other.
R1
R1#ping 172.16.0.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/6 ms

R1#ping 172.16.0.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/5 ms

R2
R2#ping 172.16.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/5 ms

R2#ping 172.16.0.6

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/3/5 ms

R3
R3#ping 172.16.0.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/5 ms

R3#ping 172.16.0.9

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.9, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/6 ms

Step 3. Configure the Ethernet interfaces of PC1 and PC3.
PC1 10.0.0.2/25 GW 10.0.0.1
PC2 10.0.0.130/25 GW 10.0.0.129

Step 4. Test connectivity between the PCs.
Should the PCs be able to ping each other at this point? No
Can they ping their default gateways? Yes

Task 2: Configure OSPF on Routers
Step 1. Enable OSPF routing on the routers.

When configuring OSPF routing, use a process ID of 1.

R1
R1#conf t
R1(config)#router ospf 1
R1(config-router)#network 172.16.0.0 0.0.0.3 area 0
R1(config-router)#network 172.16.0.8 0.0.0.3 area 0
R1(config-router)#network 10.0.0.0 0.0.0.127 area 0

R2
R2#conf t
R2(config)#router ospf 1
R2(config-router)#network 172.16.0.0 0.0.0.3 area 0
R2(config-router)#network 172.16.0.4 0.0.0.3 area 0

R3
R3#conf t
R3(config)#router ospf 1
R3(config-router)#network 172.16.0.4 0.0.0.3 area 0
R3(config-router)#network 172.16.0.8 0.0.0.3 area 0
R3(config-router)#network 10.0.0.128 0.0.0.127 area 0

Step 2. Verify that you have full network connectivity.
All routers should have routes to all networks and now be able to ping any device.

Task 3: Configure PPP Encapsulation on Serial Interfaces
Step 1. Configure PPP on the serial interfaces of all three routers.

Currently encapsulation is set to HDLC on all the serial links. In order to configure authentication later, encapsulation must be set to PPP.

Task 4: Configure PPP CHAP Authentication
The password for CHAP authentication is cisco.
Step 1. Configure PPP CHAP authentication on all serial links.

R1
R1#conf t
R1(config)#int s0/0/0
R1(config-if)#encapsulation ppp
R1(config-if)#ppp authentication chap
R1(config-if)#exit
R1(config)#username R2 password cisco
R1(config)#int s0/0/1
R1(config-if)#ppp authentication chap
R1(config-if)#exit
R1(config)#username R3 password cisco
R1(config)#exit

R2
R2#conf t
R2(config)#int s0/0/0
R2(config-if)#encapsulation ppp
R2(config-if)#ppp authentication chap
R2(config-if)#exit
R2(config)#username R1 password cisco
R2(config)#int s0/0/1
R2(config-if)#encapsulation ppp
R2(config-if)#ppp authentication chap
R2(config-if)#exit
R2(config)#username R3 password cisco
R2(config)#exit

R3
R3#conf t
R3(config)#int s0/0/0
R3(config-if)#encapsulation ppp
R3(config-if)#ppp authentication chap
R3(config-if)#exit
R3(config)#username R1 password cisco
R3(config)#int s0/0/1
R3(config-if)#encapsulation ppp
R3(config-if)#ppp authentication chap
R3(config-if)#exit
R3(config)#username R2 password cisco
R3(config-if)#exit

Step 2. Verify PPP CHAP authentication on all serial links.
Can all routers communicate with one another? Yes
Can the PC1 ping PC3? Yes

How to install teamviewer on Debian 7 testing Amd64 (wheezy)

To install Teamviewer on Debian 7 Testing md64 it is necessary to activate the multiarch.

To activate the Multiarch, the following command must be executed:
# dpkg --add-architecture i386

and then execute this command:
# apt-get update

Then proceed to Teamviewer installation:
# dpkg -i teamviewer_linux_x64.deb

In case “dpkg” complains about missing dependencies, complete the installation by executing following command:
# apt-get -f install

Info on multiarch support can be found here:

http://www.debian.org/News/2011/20110726b.en.html

Solution PT Activity 4.7.1: Packet Tracer Skills Integration Challenge

Task 1: Configure Routing
Step 1. Configure a default route to ISP.

R2
Password: cisco
R2>en
Password: class
R2#conf t
R2(config)#ip route 0.0.0.0 0.0.0.0 s0/1/0

Step 2. Configure OSPF routing between R1, R2, and R3.

R2(config)#route ospf 1
R2(config-router)#network 192.168.20.0 255.255.255.252 area 0
R2(config-router)#network 10.1.1.0 0.0.0.3 area 0
R2(config-router)#network 10.2.2.0 0.0.0.3 area 0
R2(config-router)#default-information originate
R2(config-router)#passive-interface f0/1
R2(config-router)#passive-interface s0/1/0

R1
Password: cisco
R1>en
Password: class
R1#conf t
R1(config)#router ospf 1
R1(config-router)#network 192.168.10.0 0.0.0.255 area 0
R1(config-router)#network 10.1.1.0 0.0.0.3 area 0
R1(config-router)#passive-interface f0/1

R3
Password: cisco
R3>en
Password: class
R3#conf t
R3(config)#router ospf 1
R3(config-router)#network 192.168.30.0 0.0.0.255 area 0
R3(config-router)#network 10.1.1.0 0.0.0.3 area 0
R3(config-router)#passive-interface f0/1

Task 2: Configure OSPF Authentication
Step 1. Configure MD5 authentication between R1, R2, and R3.
Configure OSPF MD5 authentication between R1, R2, and R3 using 1 as the key value and a cisco123 as the password.

R1
R1(config-router)#area 0 authentication  message-digest
R1(config-router)#exit
R1(config)#int s0/0/0
R1(config-if)#ip ospf message-digest-key 1 md5 cisco123
R1(config-if)#exit
R1(config)#

R2
R2(config-router)#area 0 authentication message-digest
R2(config-router)#exit
R2(config)#int s0/0/0
R2(config-if)#ip ospf message-digest-key 1 md5 cisco123
R2(config-if)#exit
R2(config)#
R2(config)#int s0/0/1
R1(config-if)#ip ospf message-digest-key 1 md5 cisco123
R1(config-if)#exit
R2(config)#

R3
R3(config-router)#area 0 authentication message-digest
R3(config-router)#exit
R3(config)#int s0/0/1
R3(config-if)#ip ospf message-digest-key 1 md5 cisco123
R3(config-if)#exit
R3(config)#

Task 3: Upgrade the Cisco IOS Image

Step 1. Copy a newer image from the TFTP server to flash on R2.

Look under the Config tab for the TFTP server to determine the name of the newer Cisco IOS image. Then copy the newer image to flash on R2.

Step 2. Configure R2 to boot with the new image.

R2#sh version
Cisco IOS Software, 1841 Software (C1841-IPBASE-M), Version 12.3(14)T7, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by Cisco Systems, Inc.
Compiled Mon 15-May-06 14:54 by pt_team

ROM: System Bootstrap, Version 12.3(8r)T8, RELEASE SOFTWARE (fc1)

System returned to ROM by power-on
System image file is "flash:c1841-ipbase-mz.123-14.T7.bin"

R2#copy tftp flash
Address or name of remote host []? 192.168.20.254
Source filename []? c1841-ipbasek9-mz.124-12.bin
Destination filename [c1841-ipbasek9-mz.124-12.bin]?

Accessing tftp://192.168.20.254/c1841-ipbasek9-mz.124-12.bin…
Loading c1841-ipbasek9-mz.124-12.bin from 192.168.20.254: !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[OK - 16599160 bytes]

16599160 bytes copied in 1.288 secs (2883740 bytes/sec)

R2#conf t
R2(config)#boot system flash c1841-ipbasek9-mz.124-12.bin
R2(config)#exit
R2#show flash

System flash directory:
File  Length   Name/status
  1   13832032 c1841-ipbase-mz.123-14.T7.bin
  3   16599160 c1841-ipbasek9-mz.124-12.bin
[30431192 bytes used, 2082856 available, 32514048 total]
32768K bytes of processor board System flash (Read/Write)

R2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration…
[OK]

Solved bb ascii art demo aalib no sound

To run BB with sound it is necessary to install this package:

# apt-get install alsa-oss

and then run the program with this command:

$ aoss bb