How to Solve NO_PUBKEY 85A3D26506C4AE2A

If you add Mozilla repository  in debian Testing (mozilla.debian.net) it can happen that when we try to execute the comand apt-get update, we see a GPG error:

W: GPG error: http://mozilla.debian.net experimental Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 85A3D26506C4AE2A

To solve this problem we need to install the debian-keyring package

# apt-get install debian-keyring

and then execute this 2 commands:

# gpg --keyserver keys.gnupg.net --recv-key 06C4AE2A

# gpg -a --export 06C4AE2A | apt-key add -

Solution PT Activity 3.6.1:Packet Tracer Skills Integration Challenge

The solution at PT Activity 3.6.1:Packet Tracer Skills Integration Challenge (WAN module) exercise made by me. Comment and suggestion are welcome.

 




 

Task 1: Configure PPP with CHAP Between Devices
HQ#config t
HQ(config)#username ISP password cisco
HQ(config)#interface s0/0/1
HQ(config-if)#encapsulation ppp
HQ(config-if)#ppp authentication chap
HQ(config-if)#ip address 209.165.201.2 255.255.255.252
HQ(config-if)#no sh
HQ(config-if)#exit

Task 2: Configure Full Mesh Frame Relay
HQ(config)#interface s0/0/0
HQ(config-if)#ip address 10.0.0.1 255.255.255.248
HQ(config-if)#encapsulation frame-relay
HQ(config-if)#frame-relay map ip 10.0.0.2 102 broadcast
HQ(config-if)#frame-relay map ip 10.0.0.3 103 broadcast
HQ(config-if)#frame-relay map ip 10.0.0.4 104 broadcast ietf
HQ(config-if)#frame-relay lmi-type ansi
HQ(config-if)#no sh

WEST#conf t
WEST(config)#interface s0/0/0
WEST(config-if)#ip address 10.0.0.2 255.255.255.248
WEST(config-if)#encapsulation frame-relay
WEST(config-if)#frame-relay map ip 10.0.0.1 201 broadcast
WEST(config-if)#frame-relay map ip 10.0.0.3 203 broadcast
WEST(config-if)#frame-relay map ip 10.0.0.4 204 broadcast ietf
WEST(config-if)#frame-relay lmi-type ansi
WEST(config-if)#no sh

SOUTH#conf t
SOUTH(config)#interface s0/0/0
SOUTH(config-if)#ip address 10.0.0.3 255.255.255.248
SOUTH(config-if)#encapsulation frame-relay
SOUTH(config-if)#frame-relay map ip 10.0.0.1 301 broadcast
SOUTH(config-if)#frame-relay map ip 10.0.0.2 302 broadcast
SOUTH(config-if)#frame-relay map ip 10.0.0.4 304 broadcast ietf
SOUTH(config-if)#frame-relay lmi-type ansi
SOUTH(config-if)#no sh

EAST#conf t
EAST(config)#interface s0/0/0
EAST(config-if)#ip address 10.0.0.4 255.255.255.248
EAST(config-if)#encapsulation frame-relay ietf
EAST(config-if)#frame-relay map ip 10.0.0.1 401 broadcast cisco
EAST(config-if)#frame-relay map ip 10.0.0.2 402 broadcast cisco
EAST(config-if)#frame-relay map ip 10.0.0.3 403 broadcast cisco
EAST(config-if)#frame-relay lmi-type ansi
EAST(config-if)#no sh

Task 3: Configure Static and Default Routing
HQ#conf t
HQ(config)#ip route 10.1.100.0 255.255.255.0 10.0.0.2
HQ(config)#ip route 10.1.10.0 255.255.255.0 10.0.0.3
HQ(config)#ip route 10.1.20.0 255.255.255.0 10.0.0.3
HQ(config)#ip route 10.1.30.0 255.255.255.0 10.0.0.3
HQ(config)#ip route 10.1.99.0 255.255.255.0 10.0.0.3
HQ(config)#ip route 10.1.200.0 255.255.255.0 10.0.0.4
HQ(config)#ip route 0.0.0.0 0.0.0.0 s0/0/1

WEST#conf t
WEST(config)#ip route 10.1.10.0 255.255.255.0 10.0.0.3
WEST(config)#ip route 10.1.20.0 255.255.255.0 10.0.0.3
WEST(config)#ip route 10.1.30.0 255.255.255.0 10.0.0.3
WEST(config)#ip route 10.1.99.0 255.255.255.0 10.0.0.3
WEST(config)#ip route 10.1.200.0 255.255.255.0 10.0.0.4
WEST(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.1

SOUTH#conf t
SOUTH(config)#ip route 10.1.100.0 255.255.255.0 10.0.0.2
SOUTH(config)#ip route 10.1.200.0 255.255.255.0 10.0.0.4
SOUTH(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.1

EAST#conf t
EAST(config)#ip route 10.1.100.0 255.255.255.0 10.0.0.2
EAST(config)#ip route 10.1.10.0 255.255.255.0 10.0.0.3
EAST(config)#ip route 10.1.20.0 255.255.255.0 10.0.0.3
EAST(config)#ip route 10.1.30.0 255.255.255.0 10.0.0.3
EAST(config)#ip route 10.1.99.0 255.255.255.0 10.0.0.3
EAST(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.1

Task 4: Configure and Test Inter-VLAN Routing
SOUTH#conf t
SOUTH(config)#interface fa0/0
SOUTH(config-if)#no sh
SOUTH(config-if)#exit
SOUTH(config)#interface fa0/0.10
SOUTH(config-subif)#encapsulation dot1Q 10
SOUTH(config-subif)#ip address 10.1.10.1 255.255.255.0
SOUTH(config-subif)#exit
SOUTH(config)#interface fa0/0.20
SOUTH(config-subif)#encapsulation dot1Q 20
SOUTH(config-subif)#ip address 10.1.20.1 255.255.255.0
SOUTH(config-subif)#exit
SOUTH(config)#interface fa0/0.30
SOUTH(config-subif)#encapsulation dot1Q 30
SOUTH(config-subif)#ip address 10.1.30.1 255.255.255.0
SOUTH(config-subif)#exit
SOUTH(config)#interface fa0/0.99
SOUTH(config-subif)#encapsulation dot1Q 99 native
SOUTH(config-subif)#ip address 10.1.99.1 255.255.255.0
SOUTH(config-subif)#exit

Task 5: Configure VTP and Trunking on the Switches
S1#conf t
S1(config)#vtp mode server
S1(config)#vtp domain CCNA
S1(config)#vtp password cisco

S2#conf t
S2(config)#vtp mode client
S2(config)#vtp domain CCNA
S2(config)#vtp password cisco

S3#conf t
S3(config)#vtp mode client
S3(config)#vtp domain CCNA
S3(config)#vtp password cisco

S1(config)#interface fa0/1
S1(config-if)#switchport mode trunk
S1(config-if)#switchport native vlan 99
S1(config-if)#exit

S1(config)#interface fa0/2
S1(config-if)#switchport mode trunk
S1(config-if)#switchport native vlan 99
S1(config-if)#exit

S1(config)#interface fa0/3
S1(config-if)#switchport mode trunk
S1(config-if)#switchport native vlan 99
S1(config-if)#exit

S1(config)#interface fa0/4
S1(config-if)#switchport mode trunk
S1(config-if)#switchport native vlan 99
S1(config-if)#exit

S1(config)#interface fa0/5
S1(config-if)#switchport mode trunk
S1(config-if)#switchport native vlan 99
S1(config-if)#exit

S2(config)#interface fa0/1
S2(config-if)#switchport mode trunk
S2(config-if)#switchport native vlan 99
S2(config-if)#exit

S2(config)#interface fa0/2
S2(config-if)#switchport mode trunk
S2(config-if)#switchport native vlan 99
S2(config-if)#exit

S2(config)#interface fa0/3
S2(config-if)#switchport mode trunk
S2(config-if)#switchport native vlan 99
S2(config-if)#exit

S2(config)#interface fa0/4
S2(config-if)#switchport mode trunk
S2(config-if)#switchport native vlan 99
S2(config-if)#exit

S3(config)#interface fa0/1
S3(config-if)#switchport mode trunk
S3(config-if)#switchport native vlan 99
S3(config-if)#exit

S3(config)#interface fa0/2
S3(config-if)#switchport mode trunk
S3(config-if)#switchport native vlan 99
S3(config-if)#exit

S3(config)#interface fa0/3
S3(config-if)#switchport mode trunk
S3(config-if)#switchport native vlan 99
S3(config-if)#exit

S3(config)#interface fa0/4
S3(config-if)#switchport mode trunk
S3(config-if)#switchport native vlan 99
S3(config-if)#exit

Task 6: Configure VLANs on the Switch
S1#conf t
S1(config)#vlan 10
S1(config-vlan)#name Faculty/Staff
S1(config-vlan)#vlan 20
S1(config-vlan)#name Students
S1(config-vlan)#vlan 30
S1(config-vlan)#name Guest(Default)
S1(config-vlan)#vlan 99
S1(config-vlan)#name Management&Native

Task 7: Configure and Verify VLAN 99
S1(config)#interface vlan 99
S1(config-if)#ip address 10.1.99.11 255.255.255.0
S1(config-if)#exit
S1(config)#ip default-gateway 10.1.99.1

S2(config)#interface vlan 99
S2(config-if)#ip address 10.1.99.12 255.255.255.0
S2(config-if)#exit
S2(config)#ip default-gateway 10.1.99.1

S3(config)#interface vlan 99
S3(config-if)#ip address 10.1.99.13 255.255.255.0
S3(config-if)#exit
S3(config)#ip default-gateway 10.1.99.1

Task 8: Configure S1 as Root for All Spanning Trees
S1(config)#spanning-tree vlan 1,10,20,30,99 priority 4096

Task 9: Assign Ports to VLANS
S2(config-if)#interface range f0/6 – 10
S2(config-if-range)#switchport mode access
S2(config-if-range)#switchport access vlan 10

S2(config-if)#interface range f0/11 – 15
S2(config-if-range)#switchport mode access
S2(config-if-range)#switchport access vlan 20

S2(config-if)#interface range f0/16 – 20
S2(config-if-range)#switchport mode access
S2(config-if-range)#switchport access vlan 30
S2(config-if-range)#exit

S2(config)#interface range f0/21 – 24
S2(config-if-range)#sh
S2(config-if-range)#exit

S2(config)#interface range g1/1 – 2
S2(config-if-range)#sh
S2(config-if-range)#exit

Root Motorola Xoom + Clockworkmod windows mode

I’m not responsible for any damage to your tablet, use this guide at your risk.

In this guide i’ll explain how to root and install clockworkmod on Motorola Xoom.

Prerequisites are:
- Motorola Xoom
- MicroSD
- universal root (download here)
- Recovery Tiamat RC4 (cwm) (download here)
- Working ADB and fastbook

First download and install Java JDK from this link:

Then download and install Android JDK from this link:
java SE > JDK

Fastbook and Adb should be in the same directory, so if u don’t see it, copy fastbook.exe (on Wnidows 7 C:\Program Files (x86)\Android\android-sdk\tools) in the directory where is Adb (on Windows 7 C:\Program Files (x86)\Android\android-sdk\platform-tools)

Let’s start:
Connect Motorola Xoom to PC with active USB Debugging
for activate it go to Settings>Applications>Development
and click on USB debugging

Now unlock the Motorola xoom
adb reboot bootloader
fastboot oem unlock
fastboot reboot

Flash Recovery:
Copy the file recovery-Tiamat-R4c-100611-1150-cwm.img in C:\Program Files (x86)\Android\android-sdk\platform-tools

Then on command prompt:
adb reboot bootloader
fastboot flash recovery recovery-Tiamat-R4c-100611-1150-cwm.img
fastboot reboot

After reboot connect your xoom at PC and digit:

adb reboot recovery

Your Motorola Xoom will now restart in recovery CWM and now you can flash the Universal root you copied previously on SD.

For flash any ROM go to Recovery mode and then:
“install zip from sdcard” -> “Choose zip from sdcard”
(remember to wipe before flash, if requested)

Monitor the PC temperature

This article will explain how to install lm-sensors and associated applet to control the temperature of your PC (hard disk, cpu, etc. …).

The installation begins by installing lm-sensors:
# apt-get install lm-sensors

after that we proceed to the installation of the applet:
# apt-get install sensors-applet

After installation of the sensors-applet, software will ask some questions:
start on boot (yes/no)
I suggest to select yes

Interface to listen on:
127.0.0.1

Leave as is.

Port to listen on:
7634

Leave as is.

Once you have completed the installation of sensors-applet do configuration of sensors:
# sensors-detect

All questions will be asked, answer yes (it need look for the sensors).
At question:

To load everything that is needed, add this to /etc/modules:

#—-cut here—-
# Chip drivers
coretemp
#—-cut here—-

If you have some drivers built into your kernel, the list above will
contain too many modules. Skip the appropriate ones!

Do you want to add these lines automatically to /etc/modules? (yes/NO)
I suggest to answer YES.

We're done. Now on the top panel of gnome panel, select Add and from the list select Hardware sensors monitor.